19.07.7 installing package wpad -> libubus20210603 not found


I'm trying to re-purpose an old WRT54GSv1.
I installed OpenWRT 19.07.7 (and need enterprise security WPA2-EAP) , so removed pad-mini, downloaded wpad_2019-08-08-ca8c2bd2-7_mipsel_mips32.ipk
When I however try to install it I receive the following error message:

Installing wpad (2019-08-08-ca8c2bd2-7) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for wpad:
 * 	libubus20210603
 * opkg_install_cmd: Cannot install package wpad.

What I'm missing ?



I'd venture a guess it's libubus20210603.


I'd venture a guess it's `libubus20210603

Ok …
But why a reference to a xxxxxxxx20210603 library in a 2019 codebase ?

1 Like

Thanks. I “understand” there is an “issue”.
Is there a solution for a not-so-technical user as me :innocent:
The latest supported version for my wrt54gs1 is 19.07.7, correct ? So upgrading is not an option ?

various solutions are provided in the linked thread...

I'm not sure that "various solutions" are much use for an average user. I've built OpenWRT images lots of times from sources and ImageBuilder, done "minor" ports to devices that are very similar to already supported ones, worked on a new package that is not a part of the main set, etc but after reading that thread am not sure what I would tell a friend with the OPs problem.

I think it is saying:

  1. 19.07.7 is a dead end if you want to install certain (unspecified, but including the ones in the threads) packages that happen to have got though an ABI uplift as a progression to 19.07.8.
  2. So do one or more of:
    a) wait for 19.07.8
    b) a full source-to-image build yourself.

Is that right?

1 Like

yep... that's a pretty good distillation of the relevant points

Would a rebuild from source code of only the wpad module be an option ?
Any tutorial for a not-so-technical user you could refer me to ?
FYI: I have access to a basic Ubuntu system I could use for the build process …

If I read it correctly there are dependencies on ubus in core components and in add-on packages. To keep everything happy all those things need compiling in a consistent way.

Either the core bits need nudging forwards (that's what 19.07.8 does) or the packages need to go back in time to a 19.07.7 compatible form.

Aug 1 was mentioned somewhere as when things changed I think, so rewinding a build environment to then (using suitable git commands) should give working packages, but if you have a full enough environment to do that then you may as well just move everything to 19.07.8 - if the device is supported there.

AIUI :slight_smile:

IMHO all of this is beyond the capabilities of a standard user who just wants OpenWRT to work using binaries that are available online.

Would a workable solution to this be...

  1. Ensure that the package repositories that everything prior to 19.07.8 (ie already deployed, relatively hard to change) points to will still work for those devices;
  2. Create a new 19.07b package repository, which the feeds from 19.07.8 upward inclusive point to.

Would it be better to rewind a bit and make a 19.08.n release (n=1 or 8) with it's own package repository to avoid confusion and difficulties?

Following the instructions mentioned here https://openwrt.org/docs/guide-developer/using_the_sdk I was able to ‘simply’ recompile the wpad package for release 19.07.7 and then successfully install on the wrt54gsv1.
Thanks for your suggestions.

I've never used that sort of point build, and it's a useful thing to know. Well done for finding and using it.

I think you've stepped past this potential barrier, the majority of OpenWRT users wouldn't have been able to though an an underlying problem remains:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.