19.07.1 QCA9880 Channels Hopping

Dear OpenWrt community,

Using an APU2 with 2 Compex WLE900VX (each 3 antennas), i.e. each is an independent mini-PCIe card.

  • First set to AC 80 MHz, Channel 52 (CH)
  • Second set to AC 80 MHz, Channel 100 (CH)
  • with installed packages hostapd, kmod-ath10k, kmod-ath, ath10k-firmware-qca988x.
  • both set to 18 dBm.

-> Unfortunately the second one tends to jump also to Channel 52 after some time or completely disappears :frowning:
-> Now I'm testing the first one on channel 100 and the second one on channel 52. Let's see if there will be the same effect (what I'm expecting).

How can I avoid this kind of frequency change (especially to the same as the other one, very embarrassing, makes no sense) ?

Many thanks,

cheers Blinton

Perhaps DFS is detecting a radar nearby?


As eduperez mentioned, channel 100 is a DFS channel almost everywhere. The WLAN card is mandated by law to regularly and continuosly scan for competing privileged access (read radar pulses from weather-, flight- or military radar installations) on these DFS channels - and vacate them immediately, in case radar pulses are detected. There is no grace period, actually the router has to wait a full minute (and longer, under some circumstances) and passively scan a channel for potential radar uses before it can transmit on it in the first place. If you are near (50-100km) a radar installation using these frequencies, the only option is choosing a different channel.


Looks like there is only one channel range where there is no DFS mandatory (for 80MHz). It's only embarrassing OpenWrt chooses for two distinct independent cards the same frequency range when DFS channel ranges are chosen (basically from channel 50 upwards).

Is there a way I can force the two cards from being on the same channel when they choose to switch channel range due to radars ?

No, not easily (that would need quite a bit of development to integrate).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.