19.07.03 Upgrade Error Message "The uploaded image file does not contain a supported format"

I believe that’s likely the issue here. The target profile changed from linksys-wrt1200ac*** on 18.06 releases to linksys_wrt1200ac*** on 19.07 releases.

Same thing happened with Ubiquiti EdgeRouter X. Changed from ubnt_erx*** to ubiquiti_edgerouter_x some time ago. Can confirm - force flash went through fine.


Thank you for the links. I will give it a try tomorrow.

Thank you SirToffski.

Having a similar issue with 19.07.03. I was able to build the snapshot and get it to work. I have a second WRT1200AC that will take the 19.07.03 release. Both are V1.

Using sysupgrade -F results in a non-booting install and I have to rollback to the other partition.

I'm having the same problem on WRT32X using Flash new firmware image in the web interface to openwrt OpenWrt 18.06.4.
I am using the file recommended by openwrt for my device: openwrt-19.07.3-mvebu-cortexa9-linksys_wrt32x-squashfs-factory.img
Only downloaded it twice but it results in the same error message. both times
I don't want to attempt workarounds or brick like poor andy.
Does anyone know when a file that will be recognized by my current version will be available to download?

The factory image is only for initial installation.
Use the image with sysupgrade in its name instead.

1 Like

OK I've downloaded that but I'm a little bit edgy about trying it because of this thread: WRT32X Sysupgrade Broken
WRT32X is a dual partition device designed to flash the partition-before-last
If I choose "system=>backup/flash firmware=>Flash new firmware image" using openwrt-21.02.0-rc3-mvebu-cortexa9-linksys_wrt32x-squashfs-sysupgrade
Will it definitely NOT flash the partition my functioning OpenWrt 18.06.4 is on?

Or will the sysupgrade.bin overwrite my functioning OpenWrt 18.06.4 partition?

sysupgrade in these dual-boot devices is done so that the sysupgrade overwrites the "backup partition" and switches booting to be from it. Your current firmware remains as the fallback/backup alternative.

I finally plucked up the courage to flash openwrt-21.02.0-rc3-mvebu-cortexa9-linksys_wrt32x-squashfs-sysupgrade.bin

But I got this error:
Flash new firmware image
Upload a sysupgrade-compatible image here to replace the running firmware. Check "Keep settings" to retain the current configuration (requires a compatible firmware image).
Keep settings:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.
What should I do?
Should the message "replace the running firmware" be qualified to explain not on dual-boot systems?

You have to force this upgrade because of the change to DSA switching. If you try to keep settings, the Ethernet ports will not work. So you should not keep settings, instead reconfigure 21.02 from scratch.

1 Like

At this juncture you probably want to go to RC4. As you are on a venom I thought the message would include using factory and not the sysupgrade image due to kernel reservation increase.

I downloaded openwrt-21.02.0-rc4-mvebu-cortexa9-linksys_wrt32x-squashfs-factory.img
selected Flash new firmware image
unchecked Keep settings:
But I got the same error
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

That is not a sysupgrade image...

(You downloaded "factory" for the initial installation from OEM.)

So the sysupgrade logic quite correctly points out that for you.

Thanks for your help guys, unfortunately that didn't work either:
download + flash with keep setting unchecked openwrt-21.02.0-rc4-mvebu-cortexa9-linksys_wrt32x-squashfs-sysupgrade.bin
Same message:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I was selecting the .bin files from a sub-rectory of Downloads and I wondered if the long path could be causing this so I copied it up to Downloads and tried from there but still the same error, so I think it's something else

I have a vague recollection of a previous release requiring the .bin file to be renamed, for Luci to recognize it but not what to...

Any ideas what the problem/solution could be?

Also I'm still unclear which file to use if I can get one recognized.
I have read there are significant changes in RC4 and a fresh install / configuration is the right way to
This device is dual-partition and if I understand right (have I?) the hardware flashes the alternate, rather than the current partition
So (if I could get it to recognize a file) it would flashing over the OEM firmware on the other partition, not my existing Firmware Version OpenWrt 18.06.4 r7808-ef686b7292 installation
So it wouldn't be upgrading, it would be a full fresh install to that partition and I need to use a "factory" .bin for that reason?
Anyway I can't even get it wrong yet because neither file is recognized and I'm stuck with 18.06.4 in perpetuity unless someone can help...

The message is expected, but if you still have OEM on the other partition, flip over to that partition and flash the factory RC4 image from there, leaving the OEM in place.

Just two more questions before I try this please..

This is my fault, because I don't actually KNOW the other partition has OEM firmware on it and my initial installation of OpenWrt 18.06.4 could be the ONLY firmware on the device

So I could be rebooting into empty space for all I know, and advanced reboot=>boot to alternative partition warns me:

Please also be aware that alternative partition firmware might not provide an easy way to switch active partition and boot back to the currently active partition.

Is there anything else I can try to flash from Luci?

How can I debrick if the alternative partition is not bootable / I can't flash RC4 from it?

Well, since 18.06.4 obviously seems to work for you, how about flashing 18.06.4 again as an initial step? Flashing from the active partition will only overwrite the other partition - Then your mysterious image in the other partition would turn into a known state.

Also getting familiar with the on/off button sequence to manually switch partitions seems like a good second step in your case (and actually trying it out). Documented on the wiki page of W32X.

And once all that is done the third step could be flashing 19.07.03 or other version that you wanted to try in the first place.

I read this:

and this:
Congratulations to the authors and the latter is particularly comprehensive on a variety of other issues concerning this (excellent) series of routers.

I noted:
" As of 9.20.2020 much of the below is in question. It has been determined that when using the LuCI GUI and an upgrade firmware image (not Linksys Factory to OpenWRT) that the CURRENT partition (not the other partition) will be upgraded... Sometimes... ...but not always. The pattern seems to be very erratic. This is not good. Linksys Factory to OpenWRT seems to reliably flash the other partition. None of this is noted in the OpenWRT documentation."

I asked this and got that:
root@OpenWrt:~# /usr/sbin/fw_printenv -n boot_part
From which I deduced that I had flashed Openwrt18 onto partition 2 from the OEM partition.
OEM firmware should therefore remain intact and I could use it to flash RC4-factory .img onto partition 2, not ideal but I need to configure from scratch anyway because certain fundamentals have changed between versions.

So I used advanced reboot in LUCI to reboot to the alternate partition.

For a couple of seconds I got a message / link saying something like "LUCI configuration" then the sad but familiar "could not connect" message in Firefox.

This happened every time, I tried http as well as https, so I had made a false assumption that OEM firmware was intact on partition1, and it is in fact in a brick state.
I don't know why, maybe some previous failed attempt to upgrade Openwrt.

I managed to get back to partition2 (hence I'm able to post) by switching the device on with the power button then off after 2 seconds X4, then allow to bootup fully after the 5th power on.

This was a great relief to me because I'm an Openwrt enthusiast (rather than a CLI Guru/Power-User) and I can't afford to be off-line / bricked off the internet, I have other things that require my attention.

I am now more eager than ever to get the latest version of Openwrt onto partition1 because I know it's bricked, but I'd prefer to flash it from LUCI as intended.

I read somewhere (but can't now find it) that the reason LuCI won't recognize the factory or upgrade images is something to do with headers of metdata (or something else) in the .img files.
Does anyone know more about that problem / solution?

There is no problem, and since you now believe the other partition is borked you may as well flash over whatever is there. From your current GUI flash the factory image. As stated a number of times, the messages you are seeing are expected. Just be sure you have the right image and that it is good (check sum), you can always use the power switch to flip back to the current partition from which you are flashing the new image.

1 Like