19.07.03 Upgrade Error Message "The uploaded image file does not contain a supported format"

Greetings All,

I am trying to upgrade my Linksys WRT1200ac v.1 from 18 to 19.07.03 using the Web Interface (LuCI) method. I keep getting the error message: "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

I changed the file extension from ".bin" to ".trx" and I still keep getting the same error message.

Any help would be appreciated.

Thank you,

David

The extension of the filename has no meaning, what matters is the content: you'll need the "sysupgrade" variant for your hw.

1 Like

Thank you for your reply aboaboit. I thought I did have the "sysupgrade" one:

openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-sysupgrade.trx

I don't think you need to change the file extension (or to use a trx file).

Perhaps you should download the bin file again, maybe first time it was incomplete download.

May have to force the flash from CLI, ssh into device:

cd /tmp
wget https://downloads.openwrt.org/releases/19.07.3/targets/mvebu/cortexa9/openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-sysupgrade.bin
sysupgrade -F -n openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-sysupgrade.bin

iirc the GUI does not have a Force option on the version which you are currently running. Take a backup of your config first, as that will not save things (-n).

1 Like

Where did you find it?
Try this

This was downloaded from the Openwrt Linksys WRT1200 ac page.

Hi mhegab, thank you for your input. I have downloaded the link many times (perhaps 10 times, or more) with no success.

Hi anomeome, thank you for your suggestion, Perhaps I could try CLI (I have already made a backup as I have VPN and OpenVPN configured on my router). It just still baffles me as to why LuCI wouldn't work with this upgrade. I have upgraded via LuCI before successfully.

You need to use the "Firmware OpenWrt Upgrade" file!
The "install" file is only for use when installing OpenWRT through the factory firmware.

Yes, that's what I downloaded (I did not download "Firmware OpenWrt Install").

That is odd: a format error is commonly seen when the wrong file is used.
Did you also verify the checksum? It's next to the filename in the download page

Did you flash openwrt just once till now? Remember: The wrt1200ac has two partitions and if you just flashed once, there is still the original firmware on the second - if you flash now the second time, the flash process will flash the image to the alternative partition and there "upon" the stock one.

If so, i personally would flash via "cd /tmp/ && wget https://downloads.openwrt.org/releases/19.07.3/targets/mvebu/cortexa9/openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-factory.img" following "sysupgrade -F openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-factory.img"

BTW: Check the sha256sum before flashing ...

I did this several times with my wrt1900acs without problems ...

The other typical reason for image format errors is that either device IDs or sysupgrade metadata handling have been changed between the builds.t

I don't remember if there was a relevant ID change for the mvebu target's devices between 18.06 and 19.07, but that is a possible reason. (Many devices have seen changes in their IDs (board names) included in dts.)

As WRT1200AC has the dual-boot feature, you do not lose much by trying sysupgrade -F with the 19.07 image like anomeome wrote above.

5 Likes

HI hnyman, thank you for your suggestion. I have re-downloaded the same firmware no less than 10 times - all to no avail. My other partition has DD-WRT on it.

I have never tried the sysupgrade -F process. I am not sure how to go about doing it.

Hi abysso2, thank you for your input. As I replied to nhyman earlier, I am not familiar with the sysupgrade -F process. Is it posted on the OpenWRT webpage?

Because you have dd-wrt on the second partition, i recommend

  1. backup your config via Luci
  2. connect via ssh
  3. cd /tmp
  4. wget https://downloads.openwrt.org/releases/19.07.3/targets/mvebu/cortexa9/openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-factory.img
  5. sha256sum openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-factory.img (compare result with downloadpage)
  6. sysupgrade -F openwrt-19.07.3-mvebu-cortexa9-linksys_wrt1200ac-squashfs-factory.img (router will reboot)
  7. connect to luci
  8. restore the config
  9. install additional (needed) packages

You can also try this with the linksys_wrt1900ac-squashfs-sysupgrade.bin ...

@hnyman: Your 2 cents???

Its late over here in Germany - i have to go to sleep. If you got any questions, i will check the forum tomorrow ... :blush:

You should use the sysupgrade image if you are flashing from a running Openwrt with sysyupgrade.
(And I would prefer to do the config manually after the flash, not restoring all network & wireless settings from backup.)
Otherwise ok.
(and anomeome already gave the short version of the key commands)

It is mentioned e.g. on your device's page in this section:
https://openwrt.org/toh/linksys/linksys_wrt1200ac#return_to_stock_firmware

The option -F is naturally also documented in sysupgrade reference:
https://openwrt.org/docs/techref/sysupgrade

2 Likes

I believe that’s likely the issue here. The target profile changed from linksys-wrt1200ac*** on 18.06 releases to linksys_wrt1200ac*** on 19.07 releases.

Same thing happened with Ubiquiti EdgeRouter X. Changed from ubnt_erx*** to ubiquiti_edgerouter_x some time ago. Can confirm - force flash went through fine.

Cheers