19.07.0 released today? (Jan 7, 2020)

seems like it's being released today! :slight_smile:

You can grab it here: https://downloads.openwrt.org/releases/19.07.0/targets/

1 Like

It will not be released today, as the build will not be completed today...

The final 19.07.0 was tagged yesterday and the build process in buildbot was started.
So far about half of the targets have been built during the approx 19 hours since the start of the build process:
http://buildbot.openwrt.org/openwrt-19.07/images/grid

The build will not be completed today, so the official release will not be announced today. The release announcement might come on Wednesday or Thursday.

7 Likes

@hnyman, are the package repositories also not fully updated?

I've loaded 19.07.0 final on my AP and trying to install packages results in a dependency issue. The image has 'libubox20191218' installed but the packages in the repository want to install 'libubox20170601'.

1 Like

Those package dependencies will sort themselves out once the phase2 buildbot has also built the packages with the current versions and the package indices have been refreshed in the download site.

6 Likes
  1. The bug I had in RC2 still persists into the release.
  1. I also noticed that there are both ar71xx and ath79 images for another device I own. I say this as a caution to the community - to be mindful when flashing devices that have experienced target changes over versions.

This is a consequence of the ongoing transition from ar71xx to ath79. It will be adressed in the release notes.

2 Likes

I will take care of that when updating the dataentries.
Devices with target ar71xx-ath79 will get the ath79 download links for 19.07.0 (if available).

Everything connected to the dataentries will then show the 19.07 ath79 download links.

3 Likes

Don't take it out of the oven before its done! :smile:

6 Likes

This problem is gone on Archer C7v2/5 since 19.07.0 installation.

Ref.: https://forum.openwrt.org/t/libubox-conflict-when-setting-up-a-fresh-19-07-rc-2

were you trying to repair system boards in the oven :smiley:

1 Like

The problem still exists today. Device: Netgear R7800 - arm_cortex-a15_neon-vfpv4 packages

# opkg update
...
# opkg install wpad-openssl --force-reinstall
...
# opkg remove libubus20170705
No packages removed.
Collected errors:
 * print_dependents_warning: Package libubus20170705 is depended upon by packages:
 * print_dependents_warning: 	wpad-openssl
 * print_dependents_warning: These might cease to work if package libubus20170705 is removed.

Not quite sure how you end up with that result:
the packages list in http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/base/Packages shows that the currently available wpad-openssl depends on libubus20191227

Package: wpad-openssl
Version: 2019-08-08-ca8c2bd2-1
Depends: libc, libnl-tiny, hostapd-common, libubus20191227, libopenssl1.1
Conflicts: hostapd, hostapd-basic, hostapd-mini, hostapd-openssl, hostapd-wolfssl, wpad, wpad-mesh-openssl, wpad-mesh-wolfssl, wpad-basic, wpad-mini, wpad, wpad-mesh-openssl, wpad-mesh-wolfssl, wpad-basic, wpad-mini
Provides: hostapd, wpa-supplicant

Tested with my own R7800 by installing the release firmware and installing wpad-openssl. No problems:

 -----------------------------------------------------
 OpenWrt 19.07.0, r10860-a3ffeb413b
 -----------------------------------------------------

root@router1:~# opkg list-installed | grep ubus
libubus-lua - 2019-12-27-041c9d1c-1
libubus20191227 - 2019-12-27-041c9d1c-1
ubus - 2019-12-27-041c9d1c-1
ubusd - 2019-12-27-041c9d1c-1

root@router1:~# opkg update
Downloading http://downloads.openwrt.org/releases/19.07.0/targets/ipq806x/generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading http://downloads.openwrt.org/releases/19.07.0/targets/ipq806x/generic/packages/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.0/targets/ipq806x/generic/kmods/4.14.162-1-0894164cab0effc42201a29fec8ce33f/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_kmods
Downloading http://downloads.openwrt.org/releases/19.07.0/targets/ipq806x/generic/kmods/4.14.162-1-0894164cab0effc42201a29fec8ce33f/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/base/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/luci/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/packages/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/routing/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/telephony/Packages.sig
Signature check passed.

root@router1:~# opkg remove wpad-basic
Removing package wpad-basic from root...

root@router1:~# opkg install wpad-openssl
Installing wpad-openssl (2019-08-08-ca8c2bd2-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/base/wpad-openssl_2019-08-08-ca8c2bd2-1_arm_cortex-a15_neon-vfpv4.ipk
Installing libopenssl1.1 (1.1.1d-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/arm_cortex-a15_neon-vfpv4/base/libopenssl1.1_1.1.1d-2_arm_cortex-a15_neon-vfpv4.ipk
Configuring libopenssl1.1.
Configuring wpad-openssl.

Yes, I saw the metadata as well.

It seems to be a bug with opkg. I had to fully remove the wpad-openssl package and install the package again for the dependency to be fixed. I could then remove libubus2017. The '--force-reinstall' option doesn't do what I would think it would do.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.