18.06 rc1 on TL-WR902AC v1, no IP for Client

I have installed 18.06 rc1 on my TP-Link TL-WR902AC v1 for using it as WLAN-Bridge. It is working very well, so thank you very much for this firmware.
There is only one problem: My Cable-Receiver Vu+ Uno 4K doesn't get an IP-adress with TL-WR902AC v1 as WLAN-Bridge. With the vendors firmware there was no problem with the IP-adress. Perhaps I have to configure it differently?
Please help me.

You forgot to explain your network topology. You mention wireless bridge, so there is likely another router?

How have you configured DHCP and subnets in the routers?

the main router is a Fritz!Box 7590 with and

The TL-WR902AC v1 is working very good as Bridge and has got the IP-Adress, but my Cable-Receiver doesn't get one. With the vendors firmware both get an IP-adress.

Your network topology still isn't clear to me. Are you using the TL-WR902AC v1 as an additional access point, and hence this one is connected to your fritzbox via a cable? Or are you trying to create a wireless bridge, in which the TL-WR902AC v1 is connected to your Fritzbox via WiFi?

I have created a wireless bridge, in which the TL-WR902AC v1 is connected to my Fritzbox via WiFi. And the TL-WR902AC is connected via ethernet-cable to my receiver in order to watch IPTV, YouTube and so on.
This all is working, but my receiver does not get an IP-adress.

With the vendors firmware and using TL-WR902AC v1 as WLAN-BRIDGE my receiver also get automatically an IP-adress.
Sorry for my bad English.


I think the problem is, that my main router Fritz!Box has the IP-adress and TL-WR902AC v1 (OpenWRT).

Perhaps I should change the address of TL-WR902AC to (for example)?
Or is it not recommended because of any problems?

My guess is that you don't have the wifi and ethernet interfaces bridged and/or assigned to the LAN. Basically, you want both of these physical interfaces to be working on the same network (i.e. LAN). The WR902AC should have a network address in the range if it is to work as a bridge.

Post your /etc/config/wireless and /etc/config/network files here (please put them in a 'hide details' + 'preformatted text' set of tags).

Hello psherman,

which commands do I need in telnet to get
/etc/config/network files?

LuCi is integrated in 18.06, so can I make the right configuration there and which one?

Hello again,

I hope you can help me now?


root@OpenWrt-18-06:~# uci show /etc/config/network


root@OpenWrt-18-06:~# uci show /etc/config/wireless

I had a few minutes to make my device into a dumb AP by bridging the wireless and ethernet interfaces. This was able to take a connection from ethernet (upstream) and transparently bridge it to a wifi network (this is a 'dumb AP' configuration).

I think you're trying to do the reverse, right? That is, connect to your upstream network via wifi and bridge that to ethernet. The same general configuration should work in either direction, but I did not have time to successfully connect the device to wifi as the upstream network... if I have some time later, I'll try to do that.

BTW, the way that you can get the files is to ssh into the device with username root and whatever password you have set for OpenWRT (if not set, password is blank). From there, you can view the files by using the cat command... for example:

cat /etc/config/network

Alternatively, you can use scp to copy the files between your computer and your WR902AC.

Below are the files of interest... a few important notes:

  1. you will need to set the LAN address (/etc/config/network) to one that is inside your normal network range, but not being used by any other devices and not within your main router's DHCP scope.
  2. You will also need to disable DHCP on the WR902AC to prevent a conflict on your network. Once you have set the address for the 902AC and disabled the DHCP server, you may need to manually set your IP on your computer if your computer doesn't get an IP address (for example, there is a config issue or if the wifi connection to your upstream network cannot be established.
  3. The /etc/config/wireless in my example below is not configured for an upstream network (yet)... I'll try to update that later.
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd3a:674c:c938::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask ''
	option ip6assign '60'
	option ipaddr ''
	option ifname 'eth0 radio1'
config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WR902AC'
	option encryption 'psk2'
	option key 'tl-wr902ac'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


thank you for your reply. Yes, I do the reverse and TL-WR902AC is working very good as WiFi-Bridge on my Cable-Receiver, which hasn't WiFi on board. The only problem is, that my Cable-Receiver doesn't get an own IP-adress (which is always the case, when vendors firmware is installed on TL-WR902AC).
Best regards

Just a quick update from my side...

I have been unable to get the WR902AC to act as a wifi-to-wired bridge (wifi client, simple bridge with no NAT/routing/firewalling). I haven't figured out yet if I am doing something wrong (either making a mistake during configuration or basing my config on a mistaken idea of how it should be implemented), or if there is a bug somewhere.

If I have some time, I may try the same thing with an MR3020 (the predecessor to the WR902AC) with LEDE 17.01.4. That will at least help me understand if the problem is only presenting on my WR902AC with OpenWRT 18.06.0 RC1 environment.

Got the same issue here.

After 24 hours nealy the odhcpd stopped providing ip addresses to its clients. I got an WRT1043 V2 with three subnets on it provided via wifi.


@Snotmann - I think you are dealing with an entirely different issue. This thread is about configuring the router to be a wireless-to-wired bridge (OpenWRT client wifi mode). As a bridge, it would not be responsible for any dhcp services, just transparent bridging between the wireless uplink and the downstream wired devices.

You might want to start a new thread with more details about your specific situation to see if anyone has ideas about what isn't working properly (probably best to include you network, wireless, dhcp, and firewall files from /etc/config/).

@Panther-6 -

So I had never tried to configure these devices as a wireless-to-wired bridge (wifi in client mode bridged to the ethernet LAN) since it had not been a need for me. I thought it would be simple and that maybe there was a bug in the WR902AC build for 18.06.0RC1. But I was also unable to get it to work on my MR3020 with 17.01.4. That prompted me to look for more info, and here is what I found...

Bridging as I had described (wireless-to-wired) is apparently only supported on Broadcom chipsets. See this article. So it is actually fully expected that it doesn't work on these devices.

Instead, you probably will need to use relayd as shown in this guide. Give that a shot and report back with your status.

"LAN interface of the wifi extender device MUST be on a different subnet for relayd to work (since it is routing traffic, it expects 2 different subnets)."

I have tried this (different subnet), but afterwards I had no chance to get the LuCi Login-page. No internet access on my pc, even with different subnets on it...

As my TL-WR902AC v1 is already working very good as a WiFi-Bridge with your firmware, it's not a big problem for me now, that my Cable-Receiver doesn't get an own IP-adress.
Thank you very much for your help.

It can be a bit tricky to setup things like relayd when you have a device with limited physical connectivity as it is easy to lock yourself out of the router after changing addresses and such. However, since there are two radios, you can set them up as independent networks in the LAN firewall zone and you should be able to maintain connectivity while modifying eth0 and the other radio. Or figure out all the changes and run them as either a series of UCI commands or directly edited text files that you copy into place to make a one-step change.

Anyway, good luck with whatever you decide to do.

1 Like