18.06.2 initramfs on Qemu-system-aarch64 not working

qemu-system-aarch64 -nographic -M virt -m 128 -kernel openwrt-18.06.2-armvirt-64-Image-initramfs -cpu cortex-a57

and nothing. no output, no console
With 32-bit image-initramfs it works fine
How to run arm64 version ?

I just downloaded the image and tried it with both ./scripts/qemustart and your exact command. It should work.

Is it possible that it's an issue on the downloaded image?

14e7e0b8256ff07511e333538ad320d7  openwrt-18.06.2-armvirt-64-Image-initramfs
1 Like

md5 is correct
whats your qemu version ?

my is from ubuntu 16.04
qemu-system-arm 1:2.5+dfsg-5ubuntu10

I am on CentOS 7 and use QEMU 4.0.0 compiled by myself.

May be mine is too old. Compilation is always a pain. May be try later

I compiled QEMU 2.5 and it's the same result as you described :wink:

4.0 works fine.
it was not too hard to compile. just check important features after configure and if something is missing - install -dev's

qemu-system-aarch64 -nographic -M virt -m 128 -kernel openwrt-18.06.2-armvirt-64-Image -append "root=/dev/vda ro" -drive format=raw,file=openwrt-18.06.2-armvirt-64-root.ext4 -cpu cortex-a57 -netdev bridge,id=wan -device virtio-net-pci,netdev=wan,id=wan -netdev user,id=lan --device virtio-net-pci,netdev=lan,id=lan

Another problem.

aarch64 image has support for virtio but arm32 does not
i dont know how to use ext4 image

Also nic doesnt work. Neither virtio-net-pci, e1000 or rt8139 work

Did you install the driver?

Even if it exist as kmod, it will go away after reboot. Because only ramfs is bootable
Virtio should be in-kernel as in aarch64. I think its wrong config in the build system

:confused:

You have another problem, then.

Not only me. Everybody using this

This is still an issue on the QEMU side. You need to turn off highmem for the virt machine, e.g. -M virt,highmem=off. More details can be found at http://git.openwrt.org/73c60ef239619784964e9a88c7a361ebd0c425c6

Great. working

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:
grafik

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.