18.06.1 error if lan ip not on wrt32x- partly resolved

hello -
i've had openwrt 17.x through 18.06.0 on my wrt3200, then wrt32x. for the last few weeks i've been enjoying near-flawless performance of 18.06.0 on my wrt32x, configured as main gateway for my home, with lan addr at, a bunch of other customizations and packages added. (inspired by davidc, but no this builds exactly).

this morning i upgraded to 18.06.1. i used sysupgrade over the gui, 'keep settings'
everything seemed to work, but wan not accessible.
did a 'reset' of config back to deafult, and wan was accessible.
started reconfiguring.
set password: ok.
set timeserver: ok
changed lan interface to wan not accessible. (yes, i renewed my ip lease)
from the gui: diagnostic page did ping wan addresses.
(?) so i concluded that it has something to do with the vlan/bridge config (?)
i confirmed this behavior multiple times.

back to 18.06.0 -> all ok..

any help appreciated - i can test some things if that would help.
thnak you!

update - resolved after upgrading both partitions - see below

I've noticed this issue (no luci and no ssh) also on mt7621 (mir3g) with a clean start and changed the ip with a forced apply in luci. A reboot didn't fixed it either.

Then i've done a firstboot from failsave mode and changed the ip in the config files with success.

@juppin -
did i understand you to mean the problem is in luci writing to config files?
i'm not sure that's the whole issue, since i downgraded from nonworking config on 18.06.1 (router ip at to 18.06.0 without changing/resetting config and wan was accessible.

this issue has now disappeared after upgrading both partitions on the wrt32x to 18.06.1.
i'm uncllear still as to the problem.
exact sequence:
18.06.0 -> 18.06.1 sysupgrade keep config : not working.
18.06.1 -> 18.06.0 sysupgrade keep config : working
18.06.0 -> 18.06.1 sysupgrade keep config : not working
18.06.1 -> 18.06.0 sysupgrade keep config : working
18.06.0 -> 18.06.1 sysupgrade keep config : working
18.06.1 -> 18.06.1 sysupgrade keep config : working

this sequence got 18.06.1 onto each partittion once in wan-unworking state. then reflashing while keeping config worked.

i have not tested further yet.
suggestions for testing still welcome.