18.06.1 - Associated Stations - Host in hexa

When i point to "network" -> "wireless", the " Associated Stations" show connected devices. But the column "Host" show me an hexa like ff99::99aa:ff:fff9:99f9. Is it the expected behaviour? I expected to see more friendly info, like IP or hostname.

I tried to set the names/IPs at "network" -> "hostnames" but no deal. Also tried to disable IPV6. DHCP is also down. I have another (main) router, who is DHCP server. They are connected through LAN ports.

TP-Link TL-WR741N/ND v4
OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)

Thank you for your help.

Yes, expected behavior. The AP only knows MAC addresses. The DHCP table and /etc/ethers is consulted by LuCI for a host name. If one is not found, its IP address is shown (as I recall), if one is available.

looks to be an IPv6 address, guessing that the value starts with fd or fe80

1 Like

Thank you very much. My /etc/ethers is empty.
You are right. It starts with fe80.

Should it show this way even with IPV6 off? IPV4 would be better.
Can i input data into ethers? At leat for static address i have?
What is "network" -> "hostnames" for?

Yes, you can populate /etc/ethers "by hand" -- the format for recent builds is consistent with most `nix OSes; colon-separated MAC address, whitespace, host name, one per line. Older builds might require a single space, rather than a tab or other whitespace.

Didn't you say that it's the other router that has DHCP server? Why don't you turn IPv6 off there?

1 Like

fe80 is IPv6 link-local. Any device that has IPv6 enabled must have a link-local address and will advertise it on the link.


It's a Xiaomi and i could not find where to do it. When i got some time i will change it to WRT. But it's not that quick as it was on TP-Link TL-WR741N.

Anyway, populating the ethers by hand already helped me. But it stills shows IPV6, after the name.

Good to know. I have Chromecasts and IP cameras and i'm not sure if i can disable that.

In my case, my OpenWrt is DHCP server. My PC wireless adapter has IPv6 address, temporary IPv6 address, Link-local IPv6 address and IPv4 address, but in associated station it's the IPv4 address that's showing.

I guess that means that LuCI in your case isn't aware of your IPv4 given by the other router, and therefore it uses the Link-local address.

Any chance you could use DHCP server from OpenWrt instead, if it suites you?

Better than IPV6. But names are better. In my case, i recently decided to go with static IPs, so it's easy and convenient to input the data into ethers.

Yes. But when i change the Xiaomi's firmware to WRT, i will have this problem in one of them. I need more than one Acess Point to better cover my house.

Yes, they show the names here along with IPv4.

I presume that by static you mean Static IP lease (form router side) rather than static IP at the client side? It's probably easier to manage static IPs at the router.

Now i got it. I had imagined wrong at first.

Yes. I was not clear.

I also had read your suggestion on having 2 DHCP server and had already the change. But then i read " Define additional DHCP options, for example " 6,, " which advertises different DNS servers to clients." Anyway i will give it a try.

Yes, I removed the idea of two DHCP servers as I think that putting them in the ethers is probably a lot easier and less likely to give trouble.

As for DNS, that depends on your setup. If both routers have internet from a common gateway then it should be it, otherwise if one of them feeds the other then you could put the IP of the main as the DNS of the client, or you could just use a known DNS (e.g. or