18.06.0-rc2 reaver 1.6.4-1 mips_24kc package

Hi, installed 18.06.0-rc2 r7141 on Archer C7 v4. the mips_24kc reaver 1.6.4-1 does not work.
the wash command does not have any results (this version in the official package list)
while i have a reaver 1.6.5-1 mips_24kc package that does its job.
from same location wash displays 4 APs with v1 or v2 wps and also marking correctly locked down status.
anyhow on the available routers pixiedust looks harmless. but i never succeeded pixie yet. (with kali)

also the airmon-ng has some trouble when i start a monitor at first few lines it reports unknown command "a" , or "A", something like wide output several times before finally it makes a monitor. (official package 1.2-rc2 but my rc3 behaves the same)
ath10k_pci driver shows unknown chipset while ath9k driver shows atheros AR9561 chipset.

my mdk3-v6.2 seems to work but no screen output (just 2 line feeds) so i cant follow up whats going on. (ok this can be my faulty cross compile)

i have tried them with bash shell as well instead of ash with same symptoms.

anyone experiencing something like this?

We're experiencing this problem with wash on the latest commits of Reaver on openwrt-18.06.0, and all the way to openwrt-19.07.
I've also tried building earlier versions of Reaver to try debugging it further.
We're having no issues building Reaver for openwrt 15.05.

Wash displays almost no output, and can some times print MAC addresses that should not be there. All with the ESSID: null
There seems to be a strange pattern to those few strange MAC addresses. The last two octets of the MAC always seems to be zero. Example: 50:B1:7E:10:00:00, 52:2F:6A:E6:00:00, 52:BE:6A:43:00:00

The devices we're compiling for are the Hak5 WiFi Pineapple NANO and Pineapple TETRA (ar71xx).
I'm currently trying to build using glibc instead of musl (as 15.05 is not using musl), just to see if that solves it.

I have saved stack traces of wash were the issue is occurring, and straces from the working version to compare against.
If anyone is interested in them, they are here:

OpenWRT (19.07) 30 second strace: (NOT-WORKING)

OpenWRT (15.05) 30 second strace: (WORKING)