18.04 on netgear_R7800 will never install via sysupgrade

I have Netgear R7800. From 18.04.1 onwards, it has never successfully updated via sysupgrade.

Today, I just tried to update from 18.04.2 to 18.04.6 via sysupgrade. And although the flash seemed to work in that I have internet when connected to it via a LAN cable, I cannot ssh in nor go to web-browser and connect. It will never connect to the router.

If I treat the router like it's bricked procedure and install the factory image, then I get full operation and the ability to connect to the interface via ssh and in web-browser.

What is going on? Why does sysupgrade never work with this router. I gave up today and went back to install 17.01 and the signing key is expired. Ugh!!

R7800's kernel space was enlarged and the available flash space also otherwise enlarged before 18.06.0 in June 2018. Sysupgrading from earlier builds like 17.01.x will not work. You need TFTP flash for that. That is explained in several places like

But sysupgrading between 18.06 releases, 19.07 build and master builds works quite ok. I have sysupgraded with R7800 to/from 18.06 roughly weekly since then (while testing my R7800 community build).

1 Like

Any ideas why this has never worked for me? As I explained, my most recent experience was upgrading from 18.04.2 to 18.04.6. According to you there should have been no issues. Yet failure to access LuCI has been my experience for every 18.04 to 18.04 update I have attempted (via GUI update process).

I am not talking about updating from the 17.01 to 18.04 as you mentioned.