17.01.4: Opkg_install_cmd: Cannot install package mtd (imagebuilder)

Using imagebuilder for the current release 17.01.4, target ar71xx, the package mtd seems to be missing.
I get:

Collected errors:

  • opkg_install_cmd: Cannot install package mtd.

This was working a couple of days ago. What has changed?

Source code log tells the reason:

mtd: mark as nonshared to fix FS#484 lede-17.01

As a result of that, the "mtd" package has moved from the "base" packages download repo to images downloads / packages subdir.

Not quite sure, how imagebuilder handles that move from one place to another, but likely you need to delete the temporary package database. e.g. clear the work directory, tmp and also hidden dot-starting files from tmp

mtd_21_mips24kc.ipk does exist in:

but not in:

releases/17.01-SNAPSHOT does not seem to be referenced anywhere so imagebulder does not know where to look - unless I am missing something somewhere.

I tried re-downloading imagebulder and get the same result.

Likely you need to take the 17.01 HEAD imagebuilder from

17.01.4 imagebuilder is already several months old static release build.

sorry, I first linked the 17.01.4 directory

I was going to say that's where I got it from, but then your edit appeared :slight_smile:
I will try again!
Does this mean the 17.01.4 imagebuilder is now broken?

Probably yes, as "mtd" was earlier a more generic "mips24k" package, but now it needs to be built separately for each target (lar71xx/generic, ar71xx/mikrotek, ...). so it was removed from the generic packages downloads.

@jow probably knows the logic better than me, bur I think that 17.01.4 is now broken for that.

17.01.5 is supposed to get built soon, so then there is again a release imagebuilder.

I downloaded mtd_21_mips_24kc.ipk from 17.01-SNAPSHOT and put it into my 17.01.4 Imagebuilder Packages directory and that works.

This is only a workaround of course, but at least I can produce my new firmware release now.

Thanks! :smiley: