17.01.0 on TP-Link Archer C20i fails to flash

When I try to flash the latest rc2 build to the Router on the stock firmware, the message
"Error code: 4503
The uploaded file was not accepted by the device." appears and flashing fails, or rather does not happen at all.

It is the EU version, is this the same crap as with the recent WR841 EU and US versions?


I have same issue. Just flash OpenWRT first then flash LEDE :smiley: if you use sysupgrade put -n or untick save settings in GUI :smiley:

That is not a helpful tip, flashing the trunk has bricked the device. Fortunately I'm experienced with TFTP and serial stuff.

1 Like

Did you changed the filename of the firmware to the one that original firmware is expecting?


But i found this site:

Because I totally bricked it by tftp flashing a image without uboot i had to unsolder the flash chip, program it with a raspberry pi and then solder it back on.
After that i prepared a tftp image by combining uboot from a tplink image and the latest lede image and then flashed it by holding the reset button at startup. Now it works!

1 Like

I have also the C20i AC750 and wanted to know if there is an working way to flash the router?
Thanks in advance

Ps: did someone already tried 17.01.2?

So I did flash 17.01.2 onto the device from stock FW to factory.bin and it worked,
maybe someone would like to know :wink:

1 Like

hi James, Is there any other method other than using raspberry pi to program the chip? Please let me know since I have bricked my router while tftp flashing and I dont have a raspberry pi.

There probably is, with some SPI programer. But I do not know how, I was just able to follow the instructions for the Raspberry Pi.
You could also use a Raspberry pi zero and attach it via usb to your pc. You would only need the Rpi zero, a 8gb microsd and a micro usb cable.

Thank You James. I have planned to flash using "CH341A Series 24 EEPROM Writer 25 SPI routing BIOS LCD Flash USB Programmer". I'm yet to receive the items from ebay. Anyways thanks for your help! Will let know if i'm successful in bring my router from the dead..! :wink:

Hi, Need your help here. Where did you get these files from? it's not mentioned in the page.

c20i_original.bin is the content of the flash chip created as backup. archer_firmware.bin ist described on the page how to get it.