1 Dumb AP connected to 2 different routers

Hello.

At home I have 2 raspberry pi that are connected to two different Tailscale Networks. Since the wifi of the raspberry pi is not the best, I would like to use an archer c7 v5 as a dumb AP to repeat them.
The idea is:
Raspberry Pi 1 --> LAN cable towards Lan 1 of the C7 --> to be repeated via the Wifi 1
Raspberry Pi 2 --> LAN cable towards Lan 2 of the C7 --> to be repeated via the Wifi 2

The 2 wifi have to be totally different and not connected in any way.

Is this feasible? I have created a dumb ap in the past, but I would not know how to connect another wan source to repeat it on another different wifi.

Create a new VLAN (e.g. vlan 10), bridge device and interface and attach lan2 to the second SSID.

# /etc/config/network
# Raspberry Pi 1

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option proto 'static'
        option device 'br-lan'
	    option ipaddr '...'
	    ...

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2'

# Raspberry Pi 2

config device
        option name 'br-lan2'
        option type 'bridge'
        list ports 'eth0.10'

config interface 'lan2'
        option proto 'none'
        option device 'br-lan2'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option ports '0t 3'