1.1.1.1 not connecting to my city resolver

hey guys.

i have discussed it before about cloudflare resolver not connecting to city server although we have Cloudflare dns resolver in our city too.

no matter what if i configure my openwrt router from wan or dhcp and dns it always connect to Marseille,France.

i have a tp link router with stock firmware and also configured 1.1.1.1 on this router too when i connect my devices to tp link router all my dns queries goes through my city dns server but when i connect to openwrt all the queries goes through Marseille france.

even i tried to place the tp link router between my main gpon router and openwrt router.. tp link router configure with 1.1.1.1 and openwrt router using the dns server advertised by peers

but still when i connect to openwrt it connect to Marseille france.

also the picture is attached.

Also, please include the ip addresses of all devices upstream of the OpenWrt device.

1 Like

OpenWrt does not operate cloudflare DNS.

2 Likes
login as: root
root@10.0.82.1's password:


BusyBox v1.36.1 (2024-09-23 12:34:46 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 23.05.5, r24106-10cc5fcd00
 -----------------------------------------------------
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Linksys E8450 (UBI)",
        "board_name": "linksys,e8450-ubi",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "mediatek/mt7622",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6a:848f:4a44::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.0.82.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option channel 'auto'
        option band '2g'
        option htmode 'HT40'
        option cell_density '0'
        option country 'SA'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'ZERO'
        option encryption 'psk2'
        option key '95506666'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '48'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'SA'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'ZERO'
        option encryption 'psk2'
        option key '95506666'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
root@OpenWrt:~#
  • I don't see 1.1.1.1 configured
  • The OpenWrt can't control the location of your closest CloudFlare data center
1 Like

bro what im saying is i configured my tp link router with cloudflare and then connected my openwrt router through rj45 cable to my tp link router.

now i have 2 ssid one from tp link router and one from openwrt router.

if i connect my devices to tplink router ssid all dns queries goes through my city cloudflare server.
and if i connect devices to my openwrt router ssid which is connected to tplink router through rj45 sent all queries to marsielle france.

openert router should also sent dns quries to my city clouflare data center because it is like an access point now.

OK...

OK...

Can you show a screenshot of what you mean?

Why do you believe this isn't occurring can you show us?

Is there some configuration you wish to add to the OpenWrt?

My phone is connected to to TP-Link SSID

Here my phone is connected to openwrt router SSID.

But TP-Link router is the main router with 1.1.1.1 configured and openwrt router is connected to tp link router as a sub router without configured any dns.

I really do noticed better latency when connected to my city dns server.

1 Like

You can not control anycast routing from your router alone.

2 Likes

If you had set it dumb it would, but you have it active. You have firewall rules, different subnet ( I asked you for upstream ip addresses).
Set it up as a dumb AP and get back to us.

1 Like

bro i tried Dump AP also but again same thing was happening my tplink router connection to my city dns server and openwrt router connecting same Marseille france server.

( I asked you for upstream ip addresses). really don't have an idea what is this.

now i gave up on this i will use google dns as it is connecting to nearest dns server to my city.

Please try tho folloqing from the OpenWrt device:

opkg update ; okg install mtr-json # I think that is the corect package name..
mtr -ezb4w -c 100 1.1.1.1 # this takes almost 2 minutes

Then post the output (consider reacting sensitive IP addresses, but please only the last 2 sections). In addition please tell us your city or general region...

1 Like

In dumb AP mode OpenWrt will not perform DNS resolution or configuration of client DNS servers, so unclear how this happened (I am not doubting your report, but note that should not have been possible).

1 Like

okay will do this later after i get back home.

jeddah, Sa is my region

Mmmh, it looks like a lot of submarine cables land in Jeddah, so if it truly is Marseille (where a bunch of the same cables land as well) that might not be totally terrible, but also not perfect...

1 Like

yes and i also configured one.one.one.one in my android phone and when on mobile data it gave me Jeddah, Sa result in dnsleaktest.

Edited

Check

Let me show you why the DNS server address means nothing:
I have a computer that handles all DNS requests and, depending on how it is configured, I can tell it if it gets confused to use Cloudflare directly.

While I live in the US, I do not live in Columbus and those are not the addresses I put in.

Are you 'encouraged' to use local DNS servers?

2 Likes

no i wont use local dns servers.

i tested bufferbloat speedtest 1.1.1.1 still better than all so i will continue using 1.1.1.1

Manually enter SA DNS 172.70.156.80 instead of anycast 1.1.1.1.

Still interested to see that...

3 Likes